You are here: Transforming Data > Working with Transformer Versions

Working with Transformer Versions

With new releases of FME, transformers are sometimes upgraded to include new functionality. Whenever a transformer is updated or fixed, the transformer version number increases. That is the only time the version number changes – it does not automatically increase with a new FME version. Transformer version numbering runs 0, 1, 2, 3,..., in which a new transformer is version 0. Some transformers might never change and still have a version of 0, whereas others might change three or four times between FME releases.

When you upgrade to a newer version of FME, the transformers in your workspaces do not upgrade to their latest versions. All transformers continue to work the same as they always did, according to their versions when you initially added them. If you choose, you can manually upgrade the individual transformers in your workspaces to their latest versions.

Note: You cannot open a workspace when it contains a transformer with a newer version than what is available in the current version of FME. For example, if you open an FME 2015 workspace in FME 2007, there might be a conflict in FME. That's because you may have a transformer version 4 in the workspace, while FME 2007 supports only version 1.

You can work with transformer versions in the following ways:

  • Control how transformer version numbers appear.
  • Upgrade transformers to their latest versions.

Viewing Transformer Versions

You can show the transformer version in the tooltip that displays when you mouse over a transformer. Under Tools > FME Options > Transformers, check .  

The transformer version appears in the tooltip:

In this example, the version of this AttributeRenamer transformer is 1. The current version of the AttributeRenamer transformer, in this installation of FME Desktop, is 4. That is, if you were to add a new AttributeRenamer to a workspace, it would be version 4.

The current version also appears in the list of transformers in the Navigator window:

Upgrading Transformer Versions

You can upgrade any transformer in your workspace to its latest version. Before deciding to upgrade a transformer, you can view information about how the transformer's functionality has changed between each version. During the upgrade, you can often see a comparison of the transformer's parameter settings from the current version to the new version, and make adjustments as necessary.

Transformers whose version is earlier than the latest version available appear in the Navigator, under Upgradeable Transformers. The current version, and the latest version available, both display:

To view detailed information about how the transformer has changed between versions, right-click on the transformer name (as it appears directly under Upgradeable Transformers) and select Show Changes.

In some cases, you may have a workspace that contains different versions of the same transformer. For example, if you open a workspace that has a version 2 Bufferer, and you place a new Bufferer, the new one may be version 3, or some later version.

Should You Upgrade?

Before you decide to upgrade a transformer to its latest version, investigate what has changed between versions. In some cases, the changes involve performance and functionality improvements that will not cause your workspace to behave unexpectedly after you upgrade. In other cases, an upgrade may require you to troubleshoot unexpected results. For example, there may be links that are wrong or broken, or changes in runtime behavior may cause the workspace to fail or not run at all.

Note: After upgrading a transformer, test your workspace thoroughly to ensure it behaves as expected.

See What's Changed

  1. Right-click on the transformer you are considering to upgrade, either on the Workbench Canvas, or in the Navigator, under Upgradeable Transformers.
  2. Select Upgrade Transformer. An Upgrade window opens:
    • Parameter Changes: If the selection of parameters has changed between versions, the current parameter settings display on the left of the Upgrade window, and the mapping of these settings to the upgraded parameter settings displays on the right. If any new or revised parameters require settings, they are highlighted in red. You cannot proceed with the upgrade until these missing parameters are resolved. To learn more about any new or revised parameters, click Help.
    • Note: Some transformers do not display a side-by-side comparison of parameter changes. Only the upgraded settings display.

    • Detailed Version Changes: Click Show Changes. The FME Help viewer displays detailed information about how the transformer has changed between versions.

Perform (or Cancel) the Upgrade

To proceed with upgrading, click OK in the Upgrade window. To cancel the upgrade, click Cancel.

Upgrading from Deprecated Transformers

In some cases, a transformer from a previous version of FME Desktop may have been deprecated, either because it was renamed, its function was merged into an existing transformer, or a new transformer was created that merges the functions of multiple transformers. Deprecated transformers also appear in the Navigator under Upgradeable Transformers, but are distinguished by indicating the transformer it is 'Replaced by'. In this example, the 3DPointReplacer is replaced by the VertexCreator:

The process for upgrading from a deprecated transformer is similar to that of other transformers, except the upgrade is performed in a Replace window, rather than an Upgrade window. In the following example, the parameters of the deprecated transformer, which appear on the left, map to the corresponding parameters of the replacement transformer on the right.