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Failure to Connect to Active Directory Server (Manual)

Symptom

When manually specifying Active Directory servers SECURITY_AD_SERVER_AUTODETECT=false, the following message appears in the log file:

(Active Directory) Failed to connect to an available server, or no servers were available.

Cause

When specifying Active Directory servers manually, a mistake was made in the configuration parameters.

Resolution

  • Ensure that the SECURITY_AD_SERVER_COUNT parameter is set to the number of Active Directory Servers available.
  • Ensure that the 'n' suffix in the SECURITY_AD_SERVER_HOSTn and SECURITY_AD_SERVER_PORTn parameters are correctly specified. For example:
    • SECURITY_AD_SERVER_COUNT=1 requires: SECURITY_AD_SERVER_HOST1, SECURITY_AD_SERVER_PORT1
    • SECURITY_AD_SERVER_COUNT=2 requires: SECURITY_AD_SERVER_HOST1, SECURITY_AD_SERVER_PORT1, SECURITY_AD_SERVER_HOST2, SECURITY_AD_SERVER_PORT2
    • SECURITY_AD_SERVER_COUNT=3 requires: SECURITY_AD_SERVER_HOST1, SECURITY_AD_SERVER_PORT1, SECURITY_AD_SERVER_HOST2, SECURITY_AD_SERVER_PORT2, SECURITY_AD_SERVER_HOST3, SECURITY_AD_SERVER_PORT3
  • Ensure that the host(s) and port(s) are not misspelled.
  • The port value is most commonly 389 or 636.