Failure to Connect to Active Directory Server (Auto-Detect)
Symptom
When using auto-detection of Active Directory servers SECURITY_AD_SERVER_AUTODETECT=true, the following message appears in the log file:
(Active Directory) Failed to connect to an available server, or no servers were available.
WARNING: Consider configuring a Virtual Machine (VM) via VM Console and not via Remote Desktop. You will lose connection to the VM if this configuration is done via Remote Desktop.
Cause 1
The domain name used for auto-detection may be incorrect. To check the domain used for auto-detection:
- Open a command prompt (cmd.exe) from the Start menu.
- Type ipconfig to display the network adapter settings for the computer.
- The domain name will be listed under 'Connection-specific DNS Suffix'.
- In a terminal window, type cat /etc/resolv.conf to print out DNS resolving rules for the machine.
- The domain name will be listed under 'domain' or 'search'.
The domain name used for auto-detection must match the Windows domain you are intending to use with FME Server. For information about how to obtain the fully-qualified domain name (FQDN), see SECURITY_AD_SASL_OPTION_REALM.
Resolution 1
Update the domain name used for auto-detection.
- Open 'Network and Sharing Center' from the Start menu.
- Select 'Change adapter settings' on the left-hand side.
- Right-click the network connection (commonly 'Local Area Connection'), and select Properties.
- Select 'Internet Protocol Version 4 (TCP/IPv4)' and click on 'Properties'.
- Click on 'Advanced...' to open the advanced TCP/IP settings page.
- On the 'DNS' tab, enter the FQDN into the 'DNS suffix for this connection' field.
- Click 'OK' to exit all dialogs.
- Open a command prompt (cmd.exe) from the Start Menu.
- Type ipconfig to display the network adapter settings for the computer.
- Confirm the domain name is now listed under 'Connection-specific DNS Suffix'. If it is not:
- Restart the network adapter: In the Network and Sharing Center, right-click on the same network connection and disable the connection. Right-click again and enable.
- Reboot the system. After reboot, recheck the network adapter settings.
- Modify '/etc/resolv.conf' to use the correct FQDN.
Cause 2
Auto-detection may not be available for the current Windows domain configuration.
Resolution 2
Disable auto-detection of Active Directory servers and specify them manually. For more information, see SECURITY_AD_SERVER_COUNT, SECURITY_AD_SERVER_HOST, and SECURITY_AD_SERVER_PORT.