Failure to Connect to Active Directory Server (Auto-Detect)
Symptom
When using auto-detection of Active Directory servers SECURITY_AD_SERVER_AUTODETECT=true, the following message appears in the log file:
(Active Directory) Failed to connect to an available server, or no servers were available.
WARNING: Consider configuring a Virtual Machine (VM) via VM Console and not via Remote Desktop. You will lose connection to the VM if this configuration is done via Remote Desktop.
Cause 1
The domain name used for auto-detection may be incorrect. To check the domain used for auto-detection:
The domain name used for auto-detection must match the Windows domain you are intending to use with FME Server. For information about how to obtain the fully-qualified domain name (FQDN), see SECURITY_AD_SASL_OPTION_REALM.
Resolution 1
Update the domain name used for auto-detection.
Cause 2
Auto-detection may not be available for the current Windows domain configuration.
Resolution 2
Disable auto-detection of Active Directory servers and specify them manually. For more information, see SECURITY_AD_SERVER_COUNT, SECURITY_AD_SERVER_HOST, and SECURITY_AD_SERVER_PORT.