Troubleshooting

Connecting to ArcSDE

Problems sometimes arise when attempting to connect to an ArcSDE database. This is almost always due to a misconfiguration in the user’s environment.

  • Ensure you have configured the services file so that the port number specified for the SDE instance you are connecting to matches that of the server.

Transactional Version

You cannot browse for Transactional Versions (or Tables) in the Parameters box if:

  1. Multiple SDE instances have been installed in the database,
  2. The instance you are connecting to is not the default SDE instance,
  3. You are not connecting as the user that owns the instance, or
  4. You have not manually entered a valid Transactional Version.

In that case, you must manually enter the name of a valid Transactional Version before proceeding. It will normally be “<owning username>.DEFAULT”.

Writer Error: "All channels have been allocated"

Symptom

The FME Esri ArcSDE (SDE30) writer returns an error All channels have been allocated and halts the translation.

2015-05-22 17:43:40| 4.8| 0.0|ERROR |All channels have been allocated

Cause

This error is caused when the maximum number of tables opened is exceeded.

Resolution

  1. Open the Workbench Navigator Advanced parameters (for the applicable writer).
  2. Set the Esri ArcSDE writer Advanced Parameter Max Num of Open Tables to a higher value.

Miscellaneous

  • It is not possible to write to an ArcSDE business table with one column when it is a blob column. The table must have an additional column as well.

Raster Compression

Note: Repeatedly reading and saving files may decrease the quality for this format. In addition, Workbench may not know which format data comes from, and whether it used lossy compression. If you know that source data comes from files with lossy compression, you should also set the compression level to 0. Although this compression still does not guarantee the exact copy of the source file, the output will be very close to the original.